Firefox: como instalar addons incompatíveis com versões mais novas do navegador

De Fórum Debian Wiki


Índice de conteúdo

Introdução

Quantas vezes você não tentou instalar um addon do firefox e não conseguiu porque a versão do seu firefox é mais adiantada que a da extensão que você quer? Quem já tentou instalar uma extensão e apareceu uma mensagem dizendo que não era possível porque ela não tinha um "update seguro"???

SEUS PROBLEMAS ACABARAM!!!!!

Veja como fazer todas as extensões (addons) do firefox e derivados funcionarem em seu computador, independente da versão do navegador. (tirado do site http://code.google.com/p/foxtorrent/issues/detail?id=98)

Erro de "update seguro"

Você deve desabilitar a opção de segurança especial de update, que verifica se a extensão oferece uma url de update segura.

Para desabilitar manualmente esta opção, digite na barra de endereços do firefox (ou derivado):

about:config

Depois clique com o botão direito do mouse dentro do navegador e escolha a opção New → Boolean, e coloque o nome de:

extensions.checkUpdateSecurity

Depois, deixe-o com a opção false.

Não é necessário reiniciar o navegador, o efeito é imediato. Agora basta baixar de novo a extensão que você quer e agora ela irá instalar normalmente.


Instalar uma extensão não suportada

Existe um arquivo dentro das extensões do firefox que diz até que versão aquela extensão será suportada, basta editar o arquivo e escrever até que versão do firefox você quer que ela seja suportada.

download da extensão

Baixe a extensão que quer adaptar para o seu hd (clique com o botão direito do mouse em cima do ícone de download da extensão e escolha a opção "save as" e salve no hd (não esqueça de lembrar o local onde gravou).

Renomeie a extensão que vc baixou de xpi para zip. Para isso, basta no gerenciador de arquivos, clicar com o botão direito do mouse e selecionar rename, ou basta selecionar o arquivo e apertar F2. (exeplo: minhaextensão.xpi irá ficar minhaextensão.zip)

Crie uma nova pasta (no gerenciador de arquivos, basta clicar com o botão direito dentro e escolher a opção criar novo >>pasta, e dê um nome qualquer para esta pasta).

Descompacte para esta nova pasta os arquivos contidos no arquivo minhaextensão.zip

Vá para esta nova pasta onde descarregou os arquivos descompactados e abra o arquivo chamado install.rdf com um editor de textos.

Dentro deste arquivo, procure uma linha que tenha estes escritos:

<em:maxVersion>[versão do seu firefox]</em:maxVersion>

Mude esta linha colocando no lugar de [versão do seu firefox] o número da versão do seu firefox (para sasber a versão, clique lá em cima do navegador no botão ajuda(help) >> sobre(about).

Aperte control+f para procurar no arquivo se não tem mais nenhuma linha fazendo menção à versão do navegador, se tiver, mude como feito acima, ou seja, nos campos onde aparecer a versão antiga do navegador, vc deverá substituir pela nova.

Salve e saia. Dentro da pasta que vc criou, apertar control+a (isto selecionará todos os aquivos), e deverá zipar todos estes aquivos novamente.

ATENÇÃO: NÃO É PARA ZIPAR A PASTA QUE VC CRIOU, MAS SIM, OS ARQUIVOS QUE ESTÃO DENTRO.

Para zipar, selecione os arquivos conforme descrito acima e clique com o botão direito do mouse em cima deles selecionados e escolha a opção compactar>>>>compactar como >>> Arquivo Zip. Dê o nome de minhaextensão para este novo arquivo zip, e depois, renomeie-o para minhaextensão.xpi

Agora basta abrir o firefox e clicar em ferramentas(tools) >> add-ons, e depois, arrastar e soltar o arquivo minhaextensão.xpi em cima da caixa de diálogo do "add-on" e instalá-lo normalmente.

Ferramentas pessoais